思路(实际工作中只需3、4、5、6即可):
1.用ENSP搭建这样一个网络结构环境(不一定是ENSP,这一步很重要。实际工作可能比这复杂,但技术不复杂,要好好屡屡,这既是理思路,也是留存文档的建立)
2.由4台PC,2台交换机,2台路由器构建
3.配置路由器:改路由器名字,配置console控制口密码,配置接口地址;(网络部分基本配置)
4.交换机配置console口密码(网络部分基本配置)
5.配置4台PC的IP地址(工作站基本配置)
6.配置2台路由器路由(网络路由联通配置)
第一、配置路由器:改路由器名字,配置console控制口密码,配置接口地址;
1.配置第一台路由器console口登录密码(这步不能忘,防止人为通过console线直接连接登录改动参数配置):
system-view 由用户模式进入系统模式
user-interface console 0 进入console口0
set authentication password cipher abc123 配置console口登录密码
sysname Router1 将路由器名词改成Router1
[Router1] interface GigabitEthernet0/0/1
GigabitEthernet0/0/1] ip address 192.168.100.254 24 //配IP地址
[Router1]interface GigabitEthernet 0/0/0
[Router1-GigabitEthernet0/0/0]ip address 192.168.12.1 24 //配IP地址
[Router1] display ip interface brief //查询各接口IP地址配置情况
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 3
The number of interface that is DOWN in Physical is 1
The number of interface that is UP in Protocol is 3
The number of interface that is DOWN in Protocol is 1
Interface IP Address/Mask Physical Protocol
GigabitEthernet0/0/0 192.168.12.1/24 up up
GigabitEthernet0/0/1 192.168.100.254/24 up up
GigabitEthernet0/0/2 unassigned down down
NULL0 unassigned up up(s)
2.配置第二台路由器console口登录密码:
system-view 由用户模式进入系统模式
user-interface console 0 进入console口0
set authentication password cipher abc123 配置console口登录密码
sysname Router2 将路由器名词改成Router2
[Router2] interface GigabitEthernet 0/0/0
[Router2-GigabitEthernet0/0/0] ip address 192.168.12.2 24
[Router2] interface GigabitEthernet 0/0/1
[Router2-GigabitEthernet0/0/1] ip address 192.168.200.254 24
[Router2] display ip interface brief //查询各接口IP地址配置情况
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 3
The number of interface that is DOWN in Physical is 1
The number of interface that is UP in Protocol is 3
The number of interface that is DOWN in Protocol is 1
Interface IP Address/Mask Physical Protocol
GigabitEthernet0/0/0 192.168.12.2/24 up up
GigabitEthernet0/0/1 192.168.200.254/24 up up
GigabitEthernet0/0/2 unassigned down down
NULL0 unassigned up up(s)
第二、修改交换机名称及配置console口密码
1、第一台交换机配置
system-view //由用户模式进入系统模式
sysname SW1 //修交换机提示符名称
user-interface console 0 //进入console口0
authentication-mode password //进入密码认证模式 (这点与路由器有点不同)
set authentication password cipher abc123 //配置console口登录密码
2、第二台交换机配置
system-view //由用户模式进入系统模式
sysname SW2 //修交换机提示符名称
user-interface console 0 //进入console口0
authentication-mode password //进入密码认证模式 (这点与路由器有点不同)
set authentication password cipher abc123 //配置console口登录密码
第三、配置4台PC的IP地址(依照设计图配置,网关为路由器的接口地址)
第四、配置2台路由器(打通两台路由器之间的路由)
1.配置第一台路由器路由表
ip route-static 192.168.200.0 255.255.255.0 192.168.12.2
2.配置第二进制台路由器路由表
ip route-static 192.168.100.0 255.255.255.0 192.168.12.1
3.测试工作站之间的连通性(PC1 ping PC3)
PC>ipconfig
Link local IPv6 address...........: fe80::5689:98ff:fe70:2b5d
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 192.168.100.1 //当前电脑
Subnet mask.......................: 255.255.255.0
Gateway...........................: 192.168.100.254
Physical address..................: 54-89-98-70-2B-5D
DNS server........................:
PC>ping 192.168.200.3 //另一网段电脑,连通正常
Ping 192.168.200.3: 32 data bytes, Press Ctrl_C to break
From 192.168.200.3: bytes=32 seq=1 ttl=126 time=63 ms
From 192.168.200.3: bytes=32 seq=2 ttl=126 time=78 ms
--- 192.168.200.3 ping statistics ---
3 packet(s) transmitted
2 packet(s) received
33.33% packet loss
round-trip min/avg/max = 63/70/78 ms