新建的列表添加列表推导式很简单,直接添加就好了:
text = [i for i in range(2)] print(text) ''' 运行结果: [0, 1] '''
但是,已有数据的列表里面这样添加,原有的数据就会被覆盖!
这时候,我们就要用到extend方法:
text = [1,2] text.extend([i for i in range(2)]) print(text) ''' 运行结果: [1, 2, 0, 1] '''
顺便讲一下,append和extend的区别:
append是直接生怼上去,硬加:
text = [1,2] text.append([i for i in range(2)]) print(text) ''' 运行结果: [1, 2, [0, 1]] '''
相对来说,extend会更加温柔,先拆开再加上去。
试题示例
问题描述
平面上有两个矩形,它们的边平行于直角坐标系的X轴或Y轴。对于每个矩形,我们给出它的一对相对顶点的坐标,请你编程算出两个矩形的交的面积。
输入格式
输入仅包含两行,每行描述一个矩形。
在每行中,给出矩形的一对相对顶点的坐标,每个点的坐标都用两个绝对值不超过10^7的实数表示。
输出格式
输出仅包含一个实数,为交的面积,保留到小数后两位。
样例输入
1 1 3 3
2 2 4 4
样例输出
1.00
n1 = list(map(int,input().split())) n2 = list(map(int,input().split())) x = [i for i in n1[::2]] x.extend([i for i in n2[::2]]) y = [i for i in n1[1::2]] y.extend([i for i in n2[1::2]]) x.remove(max(x)) x.remove(min(x)) y.remove(max(y)) y.remove(min(y)) if max(x)-min(x) > 0 and max(y)-min(y) < 0: print('{:.2f}'.format((max(x)-min(x))*(max(y)-min(y)))) else: print('{:.2f}'.format(0))