Java教程

PAT A1048

本文主要是介绍PAT A1048,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

1048 Find Coins (25 分)
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10
5
coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10
5
, the total number of coins) and M (≤10
3
, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the two face values V
1

and V
2

(separated by a space) such that V
1

+V
2

=M and V
1

≤V
2

. If such a solution is not unique, output the one with the smallest V
1

. If there is no solution, output No Solution instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution

#include<cstdio>
using namespace std;
int coin[100010]={false};
int c[100010];
int main()
{
	int n,m;
	scanf("%d%d",&n,&m);
	int temp;
	for(int i=0;i<n;i++)
	{
		scanf("%d",&temp);
		coin[temp]++;
		c[i]=temp;
	}
	int flag=0;
	int mv1=1000000;
	for(int i=0;i<n;i++)
	{
		int r=c[i];
		if(coin[r]&&coin[m-r]&&m-r!=r)
		{
			flag=1;
			if(mv1>r)
			mv1=r;
			if(mv1>m-r)
			mv1=m-r;
		}
		else if(m-r==r&&coin[r]>=2)
		{
			flag=1;
			if(mv1>r)
			mv1=r;
			
		}
	}
	if(flag==0)
	printf("No Solution");
	else
	printf("%d %d",mv1,m-mv1);
	return 0;
}

数字可重复

这篇关于PAT A1048的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!