C/C++教程

1107 Social Clusters (30 分)1107 Social Clusters (30 分)(并查集)

本文主要是介绍1107 Social Clusters (30 分)1107 Social Clusters (30 分)(并查集),对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:
Ki: hi[1] hi[2] ... hi[Ki]
where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

题目大意:

有n个人,每个人喜欢k个活动,如果两个人有任意一个活动相同,就称为他们处于同一个社交网络。求这n个人一共形成了多少个社交网络~

分析:

并查集。先写好init、findFather、Union。

  1. 每个社交圈的结点号是人的编号,而不是课程。课程是用来判断是否处在一个社交圈的。

  2. course[t]表示任意一个喜欢t活动的人的编号。如果当前的课程t,之前并没有人喜欢过,那么就course[t] = i,i为它自己的编号,表示i为喜欢course[t]的一个人的编号

  3. course[t]是喜欢t活动的人的编号,那么findFather(course[t])就是喜欢这个活动的人所处的社交圈子的根结点,合并根结点和当前人的编号的结点i。即Union(i, findFather(course[t])),把它们处在同一个社交圈子里面

  4. isRoot[i]表示编号i的人是不是它自己社交圈子的根结点,如果等于0表示不是根结点,如果不等于0,每次标记isRoot[findFather(i)]++,那么isRoot保存的就是如果当前是根结点,那么这个社交圈里面的总人数

  5. isRoot中不为0的编号的个数cnt就是社交圈圈子的个数

  6. 把isRoot从大到小排列,输出前cnt个,就是社交圈人数的从大到小的输出顺序

原文链接:https://blog.csdn.net/liuchuo/article/details/52191082

题解

image
image

#include <bits/stdc++.h>
using namespace std;
const int N=1010;
int father[N]; //存放父亲结点
int isRoot[N]; //记录每个结点是否作为某个集合的根节点
int course[N];

int findFather(int x){ //查找x所在集合的根节点
    int a=x;
    while(x!=father[x]){
        x=father[x];
    }
    //路径压缩
    while(a!=father[a]){
        int z=a;
        a=father[a];
        father[z]=x;
    }
    return x;
}
void Union(int a,int b){
    int faA=findFather(a);
    int faB=findFather(b);
    if(faA!=faB){
        father[faA]=faB;
    }
}
void init(int n){
    for(int i=1;i<=n;i++){
        father[i]=i;
        isRoot[i]=false;
    }
}
bool cmp(int a,int b){
    return a>b;
}
int main() {
    int n,k,h;
    cin>>n;
    init(n);
    for(int i=1;i<=n;i++){
        scanf("%d:",&k);
        for(int j=0;j<k;j++){
            cin>>h; //输入i号人喜欢的活动
            if(course[h]==0) //如果活动h第一次有人喜欢
                course[h]=i; //令i喜欢活动h
            Union(i,findFather(course[h])); //合并
        }
    }
    for(int i=1;i<=n;i++)
        isRoot[findFather(i)]++; //i的根节点是findFather(i),人数+1
    int ans=0; //记录集合数目
    for(int i=1;i<=n;i++){
        if(isRoot[i]!=0)
            ans++; //只统计isRoot[i]不为0的
    }
    cout<<ans<<endl;
    sort(isRoot+1,isRoot+n+1,cmp);
    for(int i=1;i<=ans;i++){
        cout<<isRoot[i];
        if(i<ans) cout<<" ";
    }
	return 0;
}
这篇关于1107 Social Clusters (30 分)1107 Social Clusters (30 分)(并查集)的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!