C/C++教程

C - The Frog‘s Games

本文主要是介绍C - The Frog‘s Games,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

The annual Games in frogs’ kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog’s longest jump distance).
Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
Output
For each case, output a integer standing for the frog’s ability at least they should have.

Sample Input
6 1 2
2
25 3 3
11
2
18

Sample Output
4
11

题目大意:
青蛙跳石头过河,最多跳m步,问青蛙至少拥有的跳跃能力(一步跳多远)。

解题思路:

  • 排序数组,模拟河中的石头,最后添加河对岸
  • 二分枚举答案,每一步在跳跃能力范围内尽量跳在更远的石头上,记录到达河对岸的步数
  • 如果步数>m,说明跳跃力不足,l=m+1,否则恰好是答案,或则跳跃力过强,r=m;

完整代码:

#include<iostream>
using namespace std;
int main() {
	int n,n2;
	int a[100010];
	int ma=0;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>a[i];
		ma=max(ma,a[i]);
	}
	cin>>n2;
	if(n2==1){
		cout<<ma<<endl;
		return 0;
	}
	int l=0,r=ma,m;
	while(r>l){
		m=(r+l)/2;
		long long sum=0;
		for(int i=0;i<n;i++){
			if(a[i]>m){
				sum+=(a[i]-m)/(n2-1)+((a[i]-m)%(n2-1)!=0);
			}
		}
		if(sum>m){
			l=m+1;
		}else{
			r=m;
		}
	}
	cout<<l;
}
这篇关于C - The Frog‘s Games的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!