Java教程

1147 Heaps (30 分)--PAT甲级(判断堆),写完这题心态有点小崩

本文主要是介绍1147 Heaps (30 分)--PAT甲级(判断堆),写完这题心态有点小崩,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
结尾无空行
Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
结尾无空行

题目分析:给定M个长度为N的数组的层次遍历,判断每一组是大根堆还是小根堆,还是不是堆,输出树的后续遍历。

自己死脑筋写的方法:判断是否最大堆,判断是否是最小堆,后续遍历。

#include<iostream>
#include<vector>
using namespace std;

vector<int> post;

bool maxHeap(vector<int> &arr){
	for(int i = 1; i < arr.size(); i ++){
		if(2 * i < arr.size() && arr[i] < arr[2 * i]) return false;
		if(2 * i + 1< arr.size() && arr[i] < arr[2 * i + 1]) return false;		
	}
	return true;
}
bool minHeap(vector<int> &arr){
	for(int i = 1; i < arr.size(); i ++){
		if(2 * i < arr.size() && arr[i] > arr[2 * i]) return false;
		if(2 * i + 1< arr.size() && arr[i] > arr[2 * i + 1]) return false;		
	}	
	return true;
}

void postOrder(vector<int> &arr, int i){
	if(i * 2 < arr.size()) postOrder(arr, i * 2);
	if(i * 2 + 1 < arr.size()) postOrder(arr, i * 2 + 1);
	post.push_back(arr[i]);
}

int main(){
	int m, n;
	scanf("%d %d", &m, &n);
	while(m --){
		vector<int> arr(n + 1);
		for(int i = 1; i <= n; i ++) scanf("%d", &arr[i]);
		if(maxHeap(arr)) puts("Max Heap");
		else if(minHeap(arr)) puts("Min Heap");
		else puts("Not Heap");
		post.clear();
		postOrder(arr, 1);
		for(int i = 0; i < n; i ++){
			if(i != 0) cout << ' ';
			cout << post[i];
		}
		cout << endl;
	}
	return 0;
} 

看了柳婼的代码,瞬间感觉我不适合学计算机了…

#include<iostream>
using namespace std;
int a[1005], n, m;
void postOrder(int index){
    if(index > n) return;
    postOrder(index * 2);
    postOrder(index * 2 + 1);
    printf("%d%s",a[index], index == 1 ? "\n" : " ");
}
int main(){
    scanf("%d%d", &m, &n);
    while(m --){
        int maxn = 1, minn = 1;
        for(int i = 1; i <= n; i ++) scanf("%d", &a[i]);
        for(int i = 2; i <= n; i ++){
            if(a[i] > a[i / 2]) maxn = 0;
            if(a[i] < a[i / 2]) minn = 0;
        }
        if(maxn == 1) puts("Max Heap");
        else if(minn == 1) puts("Min Heap");
        else puts("Not Heap");
        postOrder(1);
    }
    return 0;
}
这篇关于1147 Heaps (30 分)--PAT甲级(判断堆),写完这题心态有点小崩的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!